xfce4-terminal: Disable F1 shortcut

Step-by-Step descriptions of how to do things.

xfce4-terminal: Disable F1 shortcut

Postby peter_b » Wed Dec 27, 2017 9:17 pm

There are some commandline applications that offer their help on pressing the "F1"-key.
Unfortunately however, the xfce4-terminal application also has its help assigned to "F1".
This makes sense, but it's more likely that one wants to call the F1-function of the application running in the terminal instead.

Thanks to This post by user "Vadim" on superuser.com, here's how you do it:

  1. Run xfce4-appearance-settings.
  2. Click Settings tab.
  3. Check Enable editable accelerators.
  4. Click Close.
  5. Open an xfce terminal.
  6. Click the Help menu.
  7. Hover over Contents (do not click).
  8. Press the Del key to delete the accelerator.

This can generally be used to remove (and even edit!) menu keyboard-shortcuts on XFCE4 applications! Wow! :shock:
See the XFCE4 documentation article about this feature for more information.
  • 0

User avatar
peter_b
Chatterbox
 
Posts: 302
Joined: Tue Nov 12, 2013 2:05 am
Reputation: 3

Return to HowTo's

Who is online

Users browsing this forum: No registered users and 2 guests

Who is online over last 24 hours

Users browsed this forum in the last 24 hours: Google [Bot] and 8 guests

cron
Reputation System ©'