rsync: "Skipping directory"

Linux howto's, compile information, information on whatever we learned on working with linux, MACOs and - of course - Products of the big evil....

rsync: "Skipping directory"

Postby ^rooker » Sat Dec 17, 2016 2:29 am

[PROBLEM]
Rsync says "Skipping directory" when I try to copy a folder tree.

Spoiler alert! It took me 15mins now to figure out that this is a no-brainer.
Therefore I will write it down to save others the same humiliation ;)

[SOLUTION]
I didn't tell rsync to do recursion.
Just add "-r" or "-a" as option to rsync and everything's fine.

May favorite set of arguments is:
Code: Select all
rsync -avP
  • 0

Jumping out of an airplane is not a basic instinct. Neither is breathing underwater. But put the two together and you're traveling through space!
User avatar
^rooker
Site Admin
 
Posts: 1446
Joined: Fri Aug 29, 2003 8:39 pm
Reputation: 0

Return to Knowledge Base

Who is online

Users browsing this forum: No registered users and 5 guests

Who is online over last 24 hours

Users browsed this forum in the last 24 hours: No registered users and 19 guests

cron
Reputation System ©'