Fresh install of Xubuntu 16.04.3 (64bit).
After upgrading all packages to their most recent versions in the repositories, I get a problem with unmet dependency to "dpkg-dev" when trying to install build-essential:
Seems that it's unhappy with the most recent version of "libdpkg-perl":The following packages have unmet dependencies:
build-essential : Depends: dpkg-dev (>= 1.17.11) but it is not going to be installed
[SOLUTION]The following packages have unmet dependencies:
dpkg-dev : Depends: libdpkg-perl (= 1.18.4ubuntu1) but 1.18.4ubuntu1.2 is to be installed
Recommends: build-essential but it is not going to be installed
Recommends: libalgorithm-merge-perl but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
A similar issue also appears with libgtk2:
I've found a workaround, but no solution yetDepends: libgtk2.0-0 (= 2.24.30-1ubuntu1) but 2.24.30-1ubuntu1.16.04.1 is to be installed
Seems I'm not the only one encountering this problem, and I've also posted a thread about this on ubuntuforums.org.
To be continued...