Page 1 of 1

rsync: [generator] write error: Broken pipe (32)

PostPosted: Sat Jun 15, 2019 1:58 pm
by ^rooker
[PROBLEM]
Trying to copy data from an SD card onto a mounted Samba share (CIFS on Ubuntu Server 18.04). But every now and then the copy freezes and then exits with the following error message:

rsync: [generator] write error: Broken pipe (32)


dmesg says:
[197910.744340] CIFS VFS: Free previous auth_key.response = 0000000045994e04
[197915.816754] CIFS VFS: Free previous auth_key.response = 00000000696f6be9
[197933.479725] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
[198036.176476] CIFS VFS: Free previous auth_key.response = 00000000588ac411
[198036.230961] CIFS VFS: Free previous auth_key.response = 00000000424ff2d5
[198046.407852] CIFS VFS: Free previous auth_key.response = 000000005e7e5691
[198046.433682] CIFS VFS: Free previous auth_key.response = 00000000e62cd46d
[198056.585656] CIFS VFS: Free previous auth_key.response = 00000000c2b0a20f
[198056.612344] CIFS VFS: Free previous auth_key.response = 00000000c26db540
[198066.887006] CIFS VFS: Free previous auth_key.response = 00000000c2b0a20f
[198066.911506] CIFS VFS: Free previous auth_key.response = 00000000c26db540


Additionally:
CIFS VFS: No writable handles for inode


I then found this in dmesg:
CIFS VFS: Autodisabling the use of server inode numbers on \\MY_SERVER\media. This server doesn't seem to support them properly. Hardlinks will not be recognized on this mount. Consider mounting with the "noserverino" option to silence this message.



[SOLUTION]
To be continued....


Links:
https://askubuntu.com/questions/1048395 ... y-response