Debian: APT waits forever connecting to repo over IPv6

Linux howto's, compile information, information on whatever we learned on working with linux, MACOs and - of course - Products of the big evil....

Debian: APT waits forever connecting to repo over IPv6

Postby ^rooker » Tue Nov 05, 2019 2:14 pm

[PROBLEM]

On Debian 9 (Stretch), any apt action hangs at the following IPv6 host:
0% [Connecting to prod.debian.map.fastly.net (2a04:4e42:1b::204)]


[SOLUTION]
It's not really a solution, but a workaround since the IPv6 path in this network doesn't seem to be configured.

I've disabled IPv6 on that machine, since I don't need it yet:
Code: Select all
$ sysctl -w net.ipv6.conf.all.disable_ipv6=1
$ sysctl -w net.ipv6.conf.default.disable_ipv6=1


To make it permanent, add the following at the bottom of "/etc/sysctl.conf"
Code: Select all
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1


Thanks to Jack Wallen's "How to disable IPv6 on Linux" article.
  • 0

Jumping out of an airplane is not a basic instinct. Neither is breathing underwater. But put the two together and you're traveling through space!
User avatar
^rooker
Site Admin
 
Posts: 1434
Joined: Fri Aug 29, 2003 8:39 pm
Reputation: 0

Return to Knowledge Base

Who is online

Users browsing this forum: No registered users and 1 guest

Who is online over last 24 hours

Users browsed this forum in the last 24 hours: Bing [Bot] and 62 guests

cron
Reputation System ©'