APT: Packages wrongly marked as orphaned

Linux howto's, compile information, information on whatever we learned on working with linux, MACOs and - of course - Products of the big evil....

APT: Packages wrongly marked as orphaned

Postby ^rooker » Mon May 04, 2020 5:38 pm

Happens (at least to me?) every now and then and I find it a bit "unrelaxing" that sometimes a meta-package is being (marked as?) removed due one of its dependency-packages not being present.
There are different situations (perfectly reasonable and legal package install/removal use cases) that may cause this situation.

For example, after installing g++-6 (parallel to g++-7) in Xubuntu 18.04, I overlooked that some meta-package dependency became unsatisfied, therefore marking a whole bunch of vitally necessary packages as "autoremovable" :shock:

Looks like this:
The following packages were automatically installed and are no longer required:
g++ g++-7 gir1.2-harfbuzz-0.0 gir1.2-ibus-1.0 icu-devtools libapr1-dev libaprutil1-dev libasound2-dev libatk1.0-dev
libatkmm-1.6-dev libboost-filesystem1.65-dev libboost-regex1.65-dev libboost-signals1.65-dev libboost-signals1.65.1
libboost-system1.65-dev libboost1.65-dev libcairo-script-interpreter2 libcairo2-dev libcairomm-1.0-dev libcapnp-0.6.1 libcpufreq0
libdbus-c++-1-0v5 libdbus-c++-bin libecore1 libegl1-mesa-dev libeina1 libepoxy-dev libfontconfig1-dev libgdk-pixbuf2.0-dev
libgles2-mesa-dev libglib2.0-dev libglib2.0-dev-bin libglibmm-2.4-dev libgraphite2-dev libharfbuzz-dev libharfbuzz-gobject0
libibus-1.0-5 libice-dev libicu-dev libicu-le-hb-dev libicu-le-hb0 libiculx60 libldap2-dev liblog4cxx10v5 libmirclient-dev
libmirclient9 libmircommon-dev libmircommon7 libmircookie-dev libmircookie2 libmircore-dev libmircore1 libmirprotobuf3
libpango1.0-dev libpangomm-1.4-dev libpcre16-3 libpcre3-dev libpcre32-3 libpcrecpp0v5 libpixman-1-dev libprotobuf-dev
libpulse-dev libsctp-dev libsctp1 libsigc++-2.0-dev libsm-dev libsndio-dev libstdc++-6-dev libstdc++-7-dev libudev-dev
libxcomposite-dev libxcursor-dev libxft-dev libxi-dev libxinerama-dev libxkbcommon-dev libxrandr-dev libxrender-dev libxss-dev
libxt-dev libxtst-dev libxv-dev uuid-dev wayland-protocols x11proto-composite-dev x11proto-randr-dev x11proto-record-dev
x11proto-scrnsaver-dev x11proto-xinerama-dev
Use 'sudo apt autoremove' to remove them.


These packages are definitely not safe to autoremove!

Now I have to find out which dependency broke this to let my apt know that these packages shall stay.

To be continued...
  • 0

Jumping out of an airplane is not a basic instinct. Neither is breathing underwater. But put the two together and you're traveling through space!
User avatar
^rooker
Site Admin
 
Posts: 1446
Joined: Fri Aug 29, 2003 8:39 pm
Reputation: 0

Return to Knowledge Base

Who is online

Users browsing this forum: No registered users and 7 guests

Who is online over last 24 hours

Users browsed this forum in the last 24 hours: Bing [Bot], Google [Bot] and 42 guests

cron
Reputation System ©'