Xubuntu 20.04: Can't install openssh-server (dependency)

Linux howto's, compile information, information on whatever we learned on working with linux, MACOs and - of course - Products of the big evil....
Post Reply
User avatar
^rooker
Site Admin
Posts: 1469
Joined: Fri Aug 29, 2003 8:39 pm

Xubuntu 20.04: Can't install openssh-server (dependency)

Post by ^rooker »

[PROBLEM]
On a fresh install of Xubuntu 20.04.1, I can't install openssh-server :?
The following packages have unmet dependencies:
openssh-server : Depends: openssh-client (= 1:8.2p1-4)
Depends: openssh-sftp-server
Recommends: ssh-import-id but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Something's fishy here:
When I try to reinstall openssh-client, I get the following error:
Reinstallation of openssh-client is not possible, it cannot be downloaded.

[SOLUTION]

It seems that for some (yet unfortunately still unknown) reason, the "-updates" repository seems to have been enabled during install, but disabled afterwards.
So it installed newer packages (here from "focal-updates") during installation, but cannot keep up due to the package versions being "too low" in the non-updates repositories.

Strange.
Reminds me very much of a similar issue I had with VLC on 18.04 (http://www.das-werkstatt.com/forum/werk ... f=7&t=2596)

The solution is the same:
Add/enable the "-updates" repository (in /etc/apt/sources.list):

Code: Select all

deb http://at.archive.ubuntu.com/ubuntu/ YOUR_UBUNTU_VERSION_HERE-updates main restricted universe multiverse
Replace "YOUR_UBUNTU_VERSION_HERE" with the name of your distro version (bionic, focal, etc)

Fixed.
I wonder though what caused it in the first place... :|
Jumping out of an airplane is not a basic instinct. Neither is breathing underwater. But put the two together and you're traveling through space!
User avatar
^rooker
Site Admin
Posts: 1469
Joined: Fri Aug 29, 2003 8:39 pm

I know what caused it. I think.

Post by ^rooker »

It puzzled me why it appeared on so many different PCs that I've set up from scratch, and noone had noticed on the Internet except for me. That's odd. And unlikely.

So I guess the reason is that I always disable all automatic updates as one of the first things when I setup a new machine. I seriously prefer (demand!) scheduled updates where me (or my staff/colleagues) actually have the time (and nerves, just in case...) to take care of the updates' "aftershocks" and regressions. If any.

However:
The options in "Software & Updates" application, in the tab "Updates", define if your apt sources list is subscribed to "-updates" or not. I seem to have been able to select "Subscribed to: None". Strange though, that this option doesn't exist anymore in the dialog window when I open it right now.

Anyways. That's what caused it.
Jumping out of an airplane is not a basic instinct. Neither is breathing underwater. But put the two together and you're traveling through space!
Post Reply