Supermicro X9SRH-7F / ACPI issue / Windows 10 crash

Linux howto's, compile information, information on whatever we learned on working with linux, MACOs and - of course - Products of the big evil....
Post Reply
Site Admin
Posts: 444
Joined: Fri Aug 29, 2003 9:29 pm

Supermicro X9SRH-7F / ACPI issue / Windows 10 crash

Post by gilthanaz »

Using a Supermicro X9SRH-7F Board, installing Win 10 basically works (once you find the chipset and NIC drivers on the supermicro page, at least), but every warm reboot ends in a lock-up at the Windows 10 boot screen. On older Windows 10 installers without recent drivers, you might also get an "ACPI ERROR" BSOD. Funny enough, cold starts work every time (as in, turn the PSU off physically or disconnect the power cable, respectively), but using "Restart" in Windows or the Reset key of the Motherboard causes the crash in 100% of the cases, at least for my sample size.

So, after installing/trying several drivers, several re-installs of Windows 10, testing chipset drivers, checking for hardware errors (RAM etc.), changing SSD and testing other OS's (which all worked fine, surprise...), some strong google-fu gave a solution on the last hit page. And ... bingo! ... ?faq=22744

copy/pasting here for further reference if the article should go *poof*:
1) Turn off the system completely, and turn it back on, you should be able to get back into the OS.
2)Download the following driver and extract it: ... e-for-HECI
3) Open up Device Manager
4) View >> Show hidden devices
5) In the main window, expand System devices and look the device written exactly as "Intel(R) Management Engine Interface"
6) Right click on entry >> Update Driver Software
7) Click on "Browse my computer for driver software"
8 ) Click on "Let me pick from a list of device drivers on my computer"
9) Click on "Have Disk..."
10) Click on browse and navigate to where you extracted the file from step 1, then go to 'SPS_MEI_NULL_DRV_1.2.3.2003\All\patsHECI.inf'
11) Click Open >> OK >> Next >> Close
12) Restart the system
13) Go back to Device Manager and make sure you see "Intel C600 Series Management Engine Interface – 1D3A" and not "Intel(R) Management Engine Interface" in the hidden devices

Aaaaaand reboots work normal now. That was two and a half day of my life wasted ... thanks, Intel/Microsoft!
Post Reply