DaVinci Resolve on Xubuntu 22.04: Black welcome screen

Linux howto's, compile information, information on whatever we learned on working with linux, MACOs and - of course - Products of the big evil....
Post Reply
User avatar
peter_b
Chatterbox
Posts: 374
Joined: Tue Nov 12, 2013 2:05 am

DaVinci Resolve on Xubuntu 22.04: Black welcome screen

Post by peter_b »

[PROBLEM]
Downloaded and installed DaVinci Resolve v18.6.4 on Xubuntu 22.04.3.

I've enabled detailed logging on the first install (running `DaVinci_Resolve_18.6.4_Linux.run`): It was aborted with this error message:
Failed to copy file: libs/libcudnn_cnn_infer.so.8
I've tried again *without detailled logging* (knowing that sometimes changing from default-options on "not-so-Linux-native" installers may throw errors noone ran into before).
It worked. I have not changed anything to "fix this". :?

Black "Welcome Screen" trying to start Resolve:

I get a pure-black welcome splash/overlay box in the middle of the screen, then nothing happens.
The processes running in the background are:

Code: Select all

/opt/resolve/Onboarding/DaVinci_Resolve_Welcome
/opt/resolve/Onboarding/libexec/QtWebEngineProcess --type=zygote --no-sandbox --lang=en
/opt/resolve/Onboarding/libexec/QtWebEngineProcess --type=renderer --disable-accelerated-video-decode --enable-threaded-compositing --no-sandbox --use-gl=desktop --enable-deferred-image-decoding --lang=en --enable-delegated-renderer --enable-impl-side-painting --num-raster-threads=1 --channel=10487.3.238975983
[SOLUTION]
Seems to be a library version issue with "Pango" font libs.

This solved the issue for me:

Code: Select all

mkdir /opt/resolve/libs/_disabled
mv /opt/resolve/libs/libglib-2.0.so* /opt/resolve/libs/_disabled
(No "sudo" necessary, as I've installed DaVinci as current user).

Thanks to a post by user "tdworz" on Superuser.com, who wrote:
The version of Pango shipped by Fedora 38 requires Glib version 2.75.3 or newer. DaVinci Resolve ships an older version of Glib. A simple trick is to get rid of Glib shipped by DaVinci Resolve which will cause Pango to use the updated version of Glib shipped by Fedora 38.
Post Reply