Xubuntu 16.04.3: build-essential unmet dependencies

Linux howto's, compile information, information on whatever we learned on working with linux, MACOs and - of course - Products of the big evil....
Post Reply
User avatar
^rooker
Site Admin
Posts: 1469
Joined: Fri Aug 29, 2003 8:39 pm

Xubuntu 16.04.3: build-essential unmet dependencies

Post by ^rooker »

[PROBLEM]
Fresh install of Xubuntu 16.04.3 (64bit).

After upgrading all packages to their most recent versions in the repositories, I get a problem with unmet dependency to "dpkg-dev" when trying to install build-essential:
The following packages have unmet dependencies:
build-essential : Depends: dpkg-dev (>= 1.17.11) but it is not going to be installed
Seems that it's unhappy with the most recent version of "libdpkg-perl":
The following packages have unmet dependencies:
dpkg-dev : Depends: libdpkg-perl (= 1.18.4ubuntu1) but 1.18.4ubuntu1.2 is to be installed
Recommends: build-essential but it is not going to be installed
Recommends: libalgorithm-merge-perl but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
[SOLUTION]
A similar issue also appears with libgtk2:
Depends: libgtk2.0-0 (= 2.24.30-1ubuntu1) but 2.24.30-1ubuntu1.16.04.1 is to be installed
I've found a workaround, but no solution yet :(
Seems I'm not the only one encountering this problem, and I've also posted a thread about this on ubuntuforums.org.

To be continued...
Jumping out of an airplane is not a basic instinct. Neither is breathing underwater. But put the two together and you're traveling through space!
Post Reply